SKU: 96086272244

Zyxel Gs1900-24 V2 24-Port Gbe L2 Smart Switch Rackmount Fanless

Sale price$130.53 Regular price$145.03
Save 10%

Pay in installments of $36.26 with ShopPay, AfterPay and Klarna

Shipping Estimate
USA
  • USA
  • CAN

Ships within 48 hours · Estimated delivery Oct 3 - Oct 8

Promo Codes Available:

For Your Every Summer RSVP, with Code: SUMMER15

Description

Zyxel Gs1900-24 V2 24-Port Gbe L2 Smart Switch Rackmount FanlessZyxel GS1900 24 switch Gestionado Gigabit Ethernet (10 100 1000) Negro Zyxel GS1900 24, Gestionado, Gigabit Ethernet (10 100 1000) Puntos clave del producto Gestionado SNMP v1,v2,v3, RMON (1,2,3,9) Calidad de servicio (QoS) soporte Cantidad de puertos bsicos de conmutacin RJ 45 Ethernet: 24 Caractersticas de administracin Tipo de interruptor: Gestionado Calidad de servicio (QoS) soporte: Si MIB, soporte: RFC 1213 MIB II, RFC 2819, RFC 1215, RFC 1493

Zyxel Gs1900-24 V2 24-Port Gbe L2 Smart Switch Rackmount Fanless
Shipping Notes
  • Free Standard Shipping on $100+ Orders to the USA.
  • Except Preorder products are shipped in 48 hours.
  • Delivery to the USA:
  1. Standard Shipping : 3-10 business days
  • If time is of the essence, please consider selecting expedited delivery for faster service.
Exchange/Return Notes
  • We offer a 30-day return/exchange service after receiving.
  • Final sale items are not eligible for returns or exchanges.
  • To process your return/exchange, please contact us at [email protected]
  • Please click here for more details>>> Return & Exchange Policy
SKU: 96086272244

Discover Niche Categories That Outsell

Top-Converting Item to Boost Your Average Order

4.0 ★★★★★
Based on 2457 reviews
Sort
Highest Rating
Newest First
Oldest First
Product Reviews
K
Verified Purchase
Ken Wilson
Houston, US
★★★★★ 5
Good value.
Material Type: Plastic
Very convenient and great price.
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on September 23, 2025
F
Verified Purchase
Frank Estes Jr
Chelsea, US
★★★★★ 5
Utensils
Size: 1 X Pack of 180
Perfect diner ware!
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on February 10, 2026
A
Verified Purchase
Amazon Customer
Lake Worth, US
★★★★★ 5
Convenient.
Size: 1 X Pack of 180
Bought this product so many times over. Keep them stocked for special occasions as well as casual BBQ with friends. I use them to take as a hostess gift at other BBQ's, because everyone can use them. They do not bend like the other brands. The tray with the snap-on lid makes it easy use then store away.
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on May 17, 2024
Y
Verified Purchase
Yumiza Reyes
Waukegan, US
★★★★★ 5
H
Size: 1 X Pack of 180
Me gustó
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on January 14, 2026
M
Verified Purchase
Mrs. J. C.
Boise, US
★★★★★ 5
Great quality.
Size: 1 X Pack of 180
Great quality. No breakage. Nice looking. Highly recommend.
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on March 6, 2024

recommand products